Close
Login to Your Account
PRC Polaris Ranger Club - Powered by vBulletin

Polaris OEM windshield wiper problem

This is a discussion on Polaris OEM windshield wiper problem within the Ranger Discussions forums, part of the Polaris Ranger Forums category; I bought the Polaris OEM windshield wiper kit for the steel cab premium fixed windshield on my '10 XP 800. After trying to decode the ...

Results 1 to 5 of 5

Thread: Polaris OEM windshield wiper problem

  1. #1
    (Pete) Starting Member RangerXP800Rider's Avatar
    Member #
    12924
    Join Date
    Sep 2010
    Location
    Wisconsin
    Posts
    23
    Member #
    12924

    Polaris OEM windshield wiper problem

    I bought the Polaris OEM windshield wiper kit for the steel cab premium fixed windshield on my '10 XP 800. After trying to decode the instructions and really poor photo examples (appear to have been photocopied multiple times due to very blacked-out photos) I have it installed but have an over-travel issue on the driver side wiper. I cannot keep it from hitting the rubber seal that holds in the windshield. I've readjusted it on the spline of the wiper but it makes contact at the start and end of the wiper travel. The passenger side wiper works fine. Anyone else seen this issue or made any other adjustments to fix this?
    Anyone thinking of buying this expensive kit should know some other issues I have encountered:
    1) The "hood" door will no longer stay open by itelf since it makes contact with the passenger wiper preventing it from going over center and laying against the windshield. You'll need a prop rod of some sort to hold it open.
    2) Instructions are rather poor and the photo examples quality is even worse. You can figure it out since this is a rather simple kit but this could have been done much better.
    3) This kit appears to be pieced together from various manufacturers (including Wexco - who make windshield wiper assemblies) including the normal China made component (of course it is the most critical part - the motor). Although some of the linkages are custom made for this application it's not something that someone couldn't put together themselves - I'll admit it that I went the easy route and just bought the kit hoping for the best. Most of the parts are not specifically made for this Ranger install and it shows. Lots of flexng of the motor and cab indicates the linkages aren't quite right since they seem to be binding. Good thing they include a cheesy cover to cover it up.
    Thanks for any info anyone can provide on the issue I am having.
    Pete

  2. #2
    (tom) Veteran Member stroker08's Avatar
    Member #
    6117
    Join Date
    Jan 2008
    Location
    freesoil mi.
    Posts
    479
    Member #
    6117
    Liked
    4 times
    go to wexco,s web sight and they should have the instructions for timing the wiper gearbox. had a smiler prob. on my rzr with Polaris kit.

  3. #3
    1000+ Member POS POLARIS's Avatar
    Member #
    8751
    Join Date
    Mar 2009
    Location
    north country
    Posts
    2,302
    Member #
    8751
    Liked
    48 times
    I used my old OEM kit from my 2007 ranger with the curtis cab. it fit's my 2012 pro steel cab real good! I had to shave down a couple lips on the plastic washers, but other than that it works great! I don't know what position the correct wiper is in when it's off, but the different positioning of mine make the wiper stick strait up at the edge of the windshield when it's off. I'm fine with that because I can still get the hood to stay open.


    I'm getting a correct OEM kit shortly for the other 2012, so we'll see how bad mine is!
    -2006 700xp 2300hours /traded/
    -2007 700xp 1650hours /traded/
    -2012 ranger Diesel TURBO'D / 600 hours/traded/
    -2011 ranger XP / 900 hours
    -2011 ranger XP / 1600 hours
    -2012 ranger HD / 1500 hours

    Running them till the wheels fall off, repairing them, and doing it again.

  4. #4
    (Craig) Starting Member Schlich92's Avatar
    Member #
    16087
    Join Date
    Nov 2011
    Location
    MN
    Posts
    35
    Member #
    16087
    wondering if you can get a different size wiper for the single wiper......It seems like it would handle another couple of inches to clear more of the windshield.

  5. #5
    (Pete) Starting Member RangerXP800Rider's Avatar
    Member #
    12924
    Join Date
    Sep 2010
    Location
    Wisconsin
    Posts
    23
    Member #
    12924
    The problem I am seeing on the driver's side wiper is an over-travel condition so that the end of the wiper hits the windshield rubber seal at both ends of its travel. Almost seems as though the linkage ratios are not correct. The passenger side wiper works fine. I could make a part that would fix the issue but am at a loss of why it does not work properly out of the box.

    Thanks,

    Pete

Links

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  

Search tags for this page

installing polaris windshield wiper
,

my wipers stopped working on my polaris ranger how to fix

,
polaris ranger oem rubber windshield seal
,

polaris ranger windshield wiper kit

,
troubleshoot polaris ranger wipers
,
university wipers fot polaris ranger
,
windshield wipers for polaris ranger
,
windshield wipers on polaris ranger 2012 wont work
Click on a term to search our site for related topics.