Close
Login to Your Account
PRC Polaris Ranger Club - Powered by vBulletin

Lo 10.8 code

This is a discussion on Lo 10.8 code within the Ranger Discussions forums, part of the Polaris Ranger Forums category; so this is what i got....2012 800xp ...speedo flashes a "Lo 10.8..7...6...etc code" the only thing different from my 2010 is that i have a ...

Results 1 to 4 of 4

Thread: Lo 10.8 code

  1. #1
    (anthony) Starting Member viperr's Avatar
    Member #
    16524
    Join Date
    Jan 2012
    Location
    canada
    Posts
    5
    Member #
    16524

    Lo 10.8 code

    so this is what i got....2012 800xp ...speedo flashes a "Lo 10.8..7...6...etc code" the only thing different from my 2010 is that i have a deep cycle R.v battery under the seat where the storage tub sat and it is connected to a solinoid connected to the stock batt. ive read that it might be a loose connection and the 10.8 ...etc... is what the alternater is putting out (instead of 14 +/-)......anybody else ran into this????

  2. #2
    Supporting Member
    (Jerry) Moderator/Rally Committee commanderjjones's Avatar
    Member #
    3228
    Join Date
    Dec 2006
    Location
    Harriman, TN
    Posts
    19,839
    Member #
    3228
    Liked
    78 times
    You're correct.........it is indicating a low battery......10.8 volts.
    Jerry
    PRC staff / SSW staff


    2012 RZR XP4 LE liquid silver / 2006 Ranger XP LE, midnight red, built 10/25/05

  3. #3
    (anthony) Starting Member viperr's Avatar
    Member #
    16524
    Join Date
    Jan 2012
    Location
    canada
    Posts
    5
    Member #
    16524
    what other problems could bring this code up??

  4. #4
    Supporting Member
    (Jerry) Moderator/Rally Committee commanderjjones's Avatar
    Member #
    3228
    Join Date
    Dec 2006
    Location
    Harriman, TN
    Posts
    19,839
    Member #
    3228
    Liked
    78 times
    Quote Originally Posted by viperr
    what other problems could bring this code up??
    I don't think that's really a "code".......just a low battery warning.

    Unless you were running a bunch of electrical accessories and over-powering the stator, the most likely problem is a loose battery connection(s), so I'd rule that out first.

    If the connections are good, I'd probably pull the battery and take it to an auto parts to have it load tested. It might have a dead or weak cell(s).

    Some other possibilities are a bad/weak stator, bad voltage regulator, or loose/broken wires to the stator.
    Jerry
    PRC staff / SSW staff


    2012 RZR XP4 LE liquid silver / 2006 Ranger XP LE, midnight red, built 10/25/05

Links

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  

Search tags for this page

2013 ranger says lo on speedometer

,

lo code on ranger

,

rzr says lo

Click on a term to search our site for related topics.