17 Ranger crew 900 CEL
Close
Login to Your Account
PRC Polaris Ranger Club - Powered by vBulletin

17 Ranger crew 900 CEL

This is a discussion on 17 Ranger crew 900 CEL within the Ranger Technical forums, part of the Polaris Ranger Forums category; I went riding yesterday and now I have a check engine light. I did go a little deeper than usual in some water but here's ...

Page 1 of 3 123 LastLast
Results 1 to 10 of 23
Like Tree1Likes

Thread: 17 Ranger crew 900 CEL

  1. #1
    Veteran Member liftedpsd2010's Avatar
    Member #
    48234
    Join Date
    Jan 2017
    Posts
    189
    Member #
    48234
    Liked
    35 times

    17 Ranger crew 900 CEL

    I went riding yesterday and now I have a check engine light. I did go a little deeper than usual in some water but here's the codes. 3056 4 and 520344 17. Any ideas would be good. Thanks. Also I did get some intermittent power loss and check engine light going through some puddles but right when I got out they went off. Thanks for any help.

    Sent from my SAMSUNG-SGH-I537 using Tapatalk

  2. #2
    (Jim) 1000+ Member Natethedog's Avatar
    Member #
    18874
    Join Date
    Nov 2012
    Location
    Nevada
    Posts
    1,641
    Member #
    18874
    Liked
    643 times
    How deep is "a little deeper than usual"?
    2013 Ranger XP900 LE EFI EPS, Viper Elite 5000# Winch, Dragon Fire 1/2 Doors, THE Duraclutch, Firestorm Heater, 12" Totron combo light bar front and flood cubes aft, DIY game loader

  3. #3
    Veteran Member liftedpsd2010's Avatar
    Member #
    48234
    Join Date
    Jan 2017
    Posts
    189
    Member #
    48234
    Liked
    35 times
    Quote Originally Posted by Natethedog View Post
    How deep is "a little deeper than usual"?
    Top of bed. I'm snorkeled and everything is dry. Vent lines are ran up and I tired to discuss electric grease every connection I could find.

    Sent from my SAMSUNG-SGH-I537 using Tapatalk

  4. Remove Advertisements
    PRCForum.com
    Advertisements
     

  5. #4
    Veteran Member liftedpsd2010's Avatar
    Member #
    48234
    Join Date
    Jan 2017
    Posts
    189
    Member #
    48234
    Liked
    35 times
    Also to add it idles a little rough 1050-1150 rpm. I pulled the o2 sensor and cleaned it and un plugged it. Also have the batteries disconnected. Any other suggestions on what to check? The code doesn't bring much up on google.

    Sent from my SAMSUNG-SGH-I537 using Tapatalk

  6. #5
    Supporting Member
    (Forde) Super Moderator fswan's Avatar
    Member #
    13594
    Join Date
    Nov 2010
    Location
    Loganville, Georgia
    Posts
    5,028
    Member #
    13594
    Liked
    2064 times
    Cant find much on the 520344 -17. Several folks mentioned the electronic accelerator and the O2 sensor. The 3056 is below. I would look some more at O2 and the plug and wires associated with it.
    Name:  3056 code.JPG
Views: 78
Size:  28.1 KB


    My friend says to me, “What rhymes with orange?” I said, “No it doesn’t.”

    '11 800 XP - Viper Elite 4000 - EZTSK Turn Signals - Overhead Gun Rack - Backup LED - Dual Lock 'n Ride Storage Bins - Odyssey Aux 925L Battery on 1314 - H.I.D.'s - 30" LED Front, 10" LED Rear - Diamond Plate Floor Boards - Rear View Mirror w/Compass, Temp & Map Lites - 26" Bighorns - Front & Back BA arched A-Arms - Half Folding Windshield - DiamondBack Roof - Foot Saver - Dash Kit - UHMW Skids - Prolockers

    '13 RZR 900xp EPS - Medical Insurance

  7. #6
    Veteran Member liftedpsd2010's Avatar
    Member #
    48234
    Join Date
    Jan 2017
    Posts
    189
    Member #
    48234
    Liked
    35 times
    I've got it all pulled now hopefully it dries out this week and goes back to normal. This last ride was impossible to avoid water holes. 5 min in to get to camp I was over seats in water. It's wet here in florida right now.

    Sent from my SAMSUNG-SGH-I537 using Tapatalk

  8. #7
    Elite Member Ole Nasty's Avatar
    Member #
    21829
    Join Date
    Jan 2014
    Posts
    648
    Member #
    21829
    Liked
    293 times
    Everytime I would go deeper than the seat the CEL and EPS light would go on. I put my fuse box in a dry box and haven't had any problems since.


    2016 Ranger 900 XP Crew Titanium Matte
    SATV 6" lift, 32" Mudder Inlaws, Snorkeled, Full Glass Windshield

    Gone
    2015 Polaris Sportsman 570 EPS
    2014 Polaris Ranger 800 EFI
    2011 Grizzly 700 EPS
    2005 Yamaha Rhino 660
    2009 Polaris Sporstman 500HO

    Youtube-OleNasty79

    Facebook-OleNasty79

  9. #8
    Veteran Member liftedpsd2010's Avatar
    Member #
    48234
    Join Date
    Jan 2017
    Posts
    189
    Member #
    48234
    Liked
    35 times
    Did you ever get the above cel? Mines still on and running rough. Good idea on that I'll definitely do that to my box.

    Sent from my SAMSUNG-SGH-I537 using Tapatalk

  10. #9
    Elite Member Ole Nasty's Avatar
    Member #
    21829
    Join Date
    Jan 2014
    Posts
    648
    Member #
    21829
    Liked
    293 times
    I'm not sure, after a few days it would dry out and go off
    2016 Ranger 900 XP Crew Titanium Matte
    SATV 6" lift, 32" Mudder Inlaws, Snorkeled, Full Glass Windshield

    Gone
    2015 Polaris Sportsman 570 EPS
    2014 Polaris Ranger 800 EFI
    2011 Grizzly 700 EPS
    2005 Yamaha Rhino 660
    2009 Polaris Sporstman 500HO

    Youtube-OleNasty79

    Facebook-OleNasty79

  11. #10
    Veteran Member liftedpsd2010's Avatar
    Member #
    48234
    Join Date
    Jan 2017
    Posts
    189
    Member #
    48234
    Liked
    35 times
    Quote Originally Posted by Ole Nasty View Post
    I'm not sure, after a few days it would dry out and go off
    Awesome, any other issues i need to fix if I plan on going deep? And dude you need to start making money off your YouTube videos shit is hilarious every single one of them.

    Sent from my SAMSUNG-SGH-I537 using Tapatalk

Page 1 of 3 123 LastLast

Sponsored Links

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •