Close
Login to Your Account
PRC Polaris Ranger Club - Powered by vBulletin

code 51

This is a discussion on code 51 within the Ranger Technical forums, part of the Polaris Ranger Forums category; does anyone know what this code means and how to fix it?...

Results 1 to 7 of 7

Thread: code 51

  1. #1
    (Michael) Regular Member mikedirtbike's Avatar
    Member #
    12249
    Join Date
    May 2010
    Location
    walker,wv
    Posts
    54
    Member #
    12249

    code 51

    does anyone know what this code means and how to fix it?

  2. #2
    (Cesar) 1000+ Member Cesar's Avatar
    Member #
    5633
    Join Date
    Nov 2007
    Location
    Greeneville, TN. USA
    Posts
    1,773
    Member #
    5633
    Liked
    1 times
    Take a look at this:

    51: Injector 1: Open Load
    51: Injector 1: Short Circuit to Ground
    51: Injector 1: Short Circuit to Battery

    I pulled this off the important parts page on our forum. Not sure how to fix it but I'm sure Carnivore or others will chime in soon with a fix.

    2010XP, 2" Prolift, 26" Bighorns on ITP SS 108, Polaris steel cab, tool bar with spare tire mount, EMP cv boot guards, dual batteries, Viper 4000 lb. winch, fog lights, reverse lights, cab light, extreme front bumper, SuperATV extreme rear bumper, SuperATV curved front fender protectors, HID lights, Polaris custom steering wheel, Polaris running boards, Rugged Ridge fire extinguisher holder, Big Sky gun rack, Dual storage boxes, Maier Custom Hood, OTRATTW switches, Imperial Aux. fan., BA Forward A Arms.
    "keep your powder dry"
    "When in doubt...choke them out!"

  3. #3
    (Michael) Regular Member mikedirtbike's Avatar
    Member #
    12249
    Join Date
    May 2010
    Location
    walker,wv
    Posts
    54
    Member #
    12249
    Quote Originally Posted by Cesar
    Take a look at this:

    51: Injector 1: Open Load
    51: Injector 1: Short Circuit to Ground
    51: Injector 1: Short Circuit to Battery

    I pulled this off the important parts page on our forum. Not sure how to fix it but I'm sure Carnivore or others will chime in soon with a fix.
    I don't understand what that means.. this is my first FI motor.

  4. #4
    (Ken) 1000+ Member Roadrunner's Avatar
    Member #
    1331
    Join Date
    Dec 2005
    Location
    Casa Grande, AZ USA
    Posts
    6,570
    Member #
    1331
    Liked
    13 times
    What year model is your Ranger? These codes mean different things. Could be a broken wire in the fuel injector harness right at the fuel injector, could be a broken TBAP harness wire. On my 2006 Ranger it was the PCM that was tossing false codes. So we need a bit more info so we can try to help you.
    Ken

    1324 Roadrunner 12/29/05

    Casa Grande, Arizona


    www.3dflags.com

  5. #5
    (Michael) Regular Member mikedirtbike's Avatar
    Member #
    12249
    Join Date
    May 2010
    Location
    walker,wv
    Posts
    54
    Member #
    12249
    Quote Originally Posted by Roadrunner
    What year model is your Ranger? These codes mean different things. Could be a broken wire in the fuel injector harness right at the fuel injector, could be a broken TBAP harness wire. On my 2006 Ranger it was the PCM that was tossing false codes. So we need a bit more info so we can try to help you.
    sorry about that..I have a 2010 ranger 800 xp. yesterday out riding i seen the wrench fashing on the gauge so i turned the key off and on. Like i've read on here and got the 51 code..

  6. #6
    1000+ Member POS POLARIS's Avatar
    Member #
    8751
    Join Date
    Mar 2009
    Location
    north country
    Posts
    2,270
    Member #
    8751
    Liked
    40 times
    not to rain on everyone's parade here but injector codes on these units don't mean much.

    on both our 06 and 07 they have BOTH injector codes and have no running problems. These units will throw the codes for injectors even when the machine is running fine. I'm not saying that you couldn't have a problem, but if your ranger is still running fine and nothing has changed that you've noticed, I wouldn't lose a moments rest about it. our 06 ranger has had those codes since I bought it at 780 hours and still has them running the same injectors at 1950 hours. no problems.

    I talked to a few polaris techs about this and they've run into the same issue. if an injector starts running slightly outside of the computers tolerances for it, it will throw the code even when it's running fine...

    you could put a new injector in, but I would strongly advise that you're wasting your money.

    if it is running poorly, then I'd do like others suggested. check the wiring and connectors for the injectors, see if you can find any wires rubbed through or a loose connector.

    Good luck!
    -2006 700xp 2300hours /traded/
    -2007 700xp 1650hours /traded/
    -2012 ranger Diesel TURBO'D / 600 hours/traded/
    -2011 ranger XP / 900 hours
    -2011 ranger XP / 1600 hours
    -2012 ranger HD / 1500 hours

    Running them till the wheels fall off, repairing them, and doing it again.

  7. #7
    (Michael) Regular Member mikedirtbike's Avatar
    Member #
    12249
    Join Date
    May 2010
    Location
    walker,wv
    Posts
    54
    Member #
    12249
    Quote Originally Posted by POS POLARIS
    not to rain on everyone's parade here but injector codes on these units don't mean much.

    on both our 06 and 07 they have BOTH injector codes and have no running problems. These units will throw the codes for injectors even when the machine is running fine. I'm not saying that you couldn't have a problem, but if your ranger is still running fine and nothing has changed that you've noticed, I wouldn't lose a moments rest about it. our 06 ranger has had those codes since I bought it at 780 hours and still has them running the same injectors at 1950 hours. no problems.

    I talked to a few polaris techs about this and they've run into the same issue. if an injector starts running slightly outside of the computers tolerances for it, it will throw the code even when it's running fine...

    you could put a new injector in, but I would strongly advise that you're wasting your money.

    if it is running poorly, then I'd do like others suggested. check the wiring and connectors for the injectors, see if you can find any wires rubbed through or a loose connector.

    Good luck!
    thanks for the info..I'll try and pull some wire connectors and maybe put some dielectric on them to see if that's it.

Links

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  

Search tags for this page

2010 poaris ranger 800 what is code 51 mean
,
code 51 2010 polaris ranger 800 xp
,
polaris error code 51 on ranger xp 800
,

polaris ranger 800 code 51

Click on a term to search our site for related topics.