2010 RZR-S -- Running thru starters!!
Close
Login to Your Account
PRC Polaris Ranger Club - Powered by vBulletin

2010 RZR-S -- Running thru starters!!

This is a discussion on 2010 RZR-S -- Running thru starters!! within the RZR Technical forums, part of the Polaris RZR Forums category; I am posting this for a friend. He bought a used 2010 RZR-S a few months ago. He has had 2 starters go out in ...

Results 1 to 5 of 5

Thread: 2010 RZR-S -- Running thru starters!!

  1. #1
    (John) Veteran Member jlwilson's Avatar
    Member #
    19760
    Join Date
    Apr 2013
    Location
    Little Rock, AR
    Posts
    170
    Member #
    19760
    Liked
    1 times

    2010 RZR-S -- Running thru starters!!

    I am posting this for a friend.

    He bought a used 2010 RZR-S a few months ago. He has had 2 starters go out in this time. He contacted the previous owner and he too had replaced the starter twice.

    He has checked all connections and everything looks okay. The previous owner did mention that he placed a new battery (optima red top) in the RZR before this started occuring, but I cannot think of anything a different battery would be doing to hurt the starter (it is a good charged Optima battery).

    Can anyone provide some suggestions for him??

  2. #2
    (Doug) Retired Moderator seasonedsole's Avatar
    Member #
    3083
    Join Date
    Dec 2006
    Location
    Berwick, Pa.
    Posts
    4,371
    Member #
    3083
    I think I'd check the volts while cranking, maybe bad connection, wire, or even battery post.
    Doug, NE Pa.




  3. #3
    (KEITH) Starting Member keeter's Avatar
    Member #
    16633
    Join Date
    Jan 2012
    Location
    Winston Salem, NC, Hilltop Escape, WV
    Posts
    4
    Member #
    16633
    I also would like to figure this out as I have to replace my starter every 8 to 12 months, having gone thru 3 now on my 09 800 le since Sept 2011. This was happening with stock battery and with an Advance battery. Most of the time I notice it will start to hesitate when trying to crank or even click the solenoid at times then soon thereafter it will completely quit and when removing it it will be locked up completely or one time the magnet inside of it was loose and was real ruff feeling when trying to spin the shaft on it. Everytime the shaft spline was in great shape and clean from the O-rings to the shaft so no trash issues either. I also wash with a water hose or low pressure elect pressure washer after each weekend riding too. I also have had to replace a regulator and solenoid at least once too. Any suggestions?

  4. Remove Advertisements
    PRCForum.com
    Advertisements
     

  5. #4
    (Kart) Starting Member duster's Avatar
    Member #
    20940
    Join Date
    Oct 2013
    Location
    USA
    Posts
    21
    Member #
    20940
    Does the starter motor burn after sometime of usage? Or its a mechanical failure?

  6. #5
    Veteran Member Da Duke's Avatar
    Member #
    27176
    Join Date
    Sep 2015
    Location
    Mena, Arkansas
    Posts
    215
    Member #
    27176
    Liked
    126 times
    Wilson, This may apply to you. In some modifications to trucks and cars where I have installed headers I had to fabricate a heat shield and install it between the header and starter. See if it is getting to hot>

Sponsored Links

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  

Search tags for this page

had to replace my starter twice

,

polaris rzr starters

,

rzr starter removal

,

starter for 2010 rzr s

,

super atv rzr starter

Click on a term to search our site for related topics.