Ride Command keeps turning off.
Close
Login to Your Account
PRC Polaris Ranger Club - Powered by vBulletin

Ride Command keeps turning off.

This is a discussion on Ride Command keeps turning off. within the Ranger XP 1000 Discussions forums, part of the Polaris Ranger Forums category; So I just picked up a 2019 Northstar with ride command. The ride command turns off every 5-10 seconds and turns back on. Dealer will ...

Results 1 to 8 of 8

Thread: Ride Command keeps turning off.

  1. #1
    (Phil) Starting Member Phildo's Avatar
    Join Date
    Jul 2009
    Location
    Phoenix, AZ
    Posts
    22
    Member #
    9492
    Liked
    19 times

    Ride Command keeps turning off.

    So I just picked up a 2019 Northstar with ride command. The ride command turns off every 5-10 seconds and turns back on. Dealer will be 2 weeks to look at it. What should I look for to resolve this? Battery is tight and voltage is good.

  2. #2
    Elite Member summermn's Avatar
    Join Date
    Feb 2019
    Location
    South TX winter, MN summer
    2015 900xp le
    Posts
    535
    Member #
    76071
    Liked
    201 times
    Sounds like a breaker getting warm then resetting. I doubt if theres any schematic available

  3. #3
    1000+ Member Rangerwhit's Avatar
    Join Date
    Feb 2017
    Posts
    1,667
    Member #
    49442
    Liked
    442 times
    What is ride command? Have an 07. Just curious...
    2007 Ranger 500 (Carb)

  4. Remove Advertisements
    PRCForum.com
    Advertisements
     

  5. #4
    Elite Member summermn's Avatar
    Join Date
    Feb 2019
    Location
    South TX winter, MN summer
    2015 900xp le
    Posts
    535
    Member #
    76071
    Liked
    201 times
    Nearly 2k$ gps with front and rear dash cameras. Overly simplified and jealous. I do like the upgraded instruments on the 1000xp but the ride command is IMO a bit much for what it is
    Polaris is playing it up pretty good

  6. #5
    1000+ Member Rangerwhit's Avatar
    Join Date
    Feb 2017
    Posts
    1,667
    Member #
    49442
    Liked
    442 times
    Electrical, gotcha. Hot light is all I have. He needs to jump the 2k command cameras. lol.... Check fuses and all.
    2007 Ranger 500 (Carb)

  7. #6
    1000+ Member Rangerwhit's Avatar
    Join Date
    Feb 2017
    Posts
    1,667
    Member #
    49442
    Liked
    442 times
    Schedule an oil change and mention any issues you have once there. Saved you a week or more!
    2007 Ranger 500 (Carb)

  8. #7
    (Phil) Starting Member Phildo's Avatar
    Join Date
    Jul 2009
    Location
    Phoenix, AZ
    Posts
    22
    Member #
    9492
    Liked
    19 times
    Yeah, looks like it’s going to the dealer. Aggravating, but hopefully they fix it.

  9. #8
    (Rod) Starting Member Rod172's Avatar
    Join Date
    Oct 2018
    Location
    Northern Michigan
    19 Ranger Northstar
    Posts
    3
    Member #
    74617
    Liked
    4 times
    They had a bad batch, had two consecutive units with same problem. Polaris replaced with newer production run and it’s been great. 2019 Northstar year old next month.

Sponsored Links

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •