PRC Polaris Ranger Club banner

1 - 6 of 6 Posts

·
Registered
Joined
·
13 Posts
Discussion Starter #1
Just traded for a 2000 Ranger 1000 Premium (non-XP). Have had the check engine light come on twice now. Was able to get the codes tonight. 65590, 65591, 65592. I have searched and found these are misfire codes. But the machine doesn’t seem to misfire. However the clutch became really jumpy at about 10 or 11 hours and it unusually loud. I’ve heard that this can cause these codes also. Belt slippage, mis-aligned? I’m going to call dealer tomorrow as it’s obviously still under warranty. But would welcome any thoughts. The more I read the more I want the gillomen tune and clutch kit but hate to cause warranty issues as I have a two year warranty on it.
Any thoughts appreciated. Thanks
 

·
Registered
Joined
·
1,419 Posts
I'd get it to the dealer like you said. I've read of a few cases recently of the secondary bolt coming loose. Could be causing your codes and noises.
 

·
Registered
Joined
·
13 Posts
Discussion Starter #5
Thanks RJ. I'll be calling them today. Haven't heard of the bolt issue in the secondary. Appreciate the input.
 

·
Registered
Joined
·
3 Posts
Just traded for a 2000 Ranger 1000 Premium (non-XP). Have had the check engine light come on twice now. Was able to get the codes tonight. 65590, 65591, 65592. I have searched and found these are misfire codes. But the machine doesn’t seem to misfire. However the clutch became really jumpy at about 10 or 11 hours and it unusually loud. I’ve heard that this can cause these codes also. Belt slippage, mis-aligned? I’m going to call dealer tomorrow as it’s obviously still under warranty. But would welcome any thoughts. The more I read the more I want the gillomen tune and clutch kit but hate to cause warranty issues as I have a two year warranty on it.
Any thoughts appreciated. Thanks
Is it going into limp mode?
 
1 - 6 of 6 Posts
Top