PRC Polaris Ranger Club banner

1 - 3 of 3 Posts

·
Registered
Joined
·
25 Posts
Discussion Starter #1
I just got a 2010 ranger crew 800 handle weeks ago and have been having an issue with it shutting down while going on 5 to 10 minute ride at close to full throttle. when it shuts down it will act like it is not getting any fuel and sputter and backfire and then come to a stop. Kind of like a fule filter stopped up. I will get off and open up the gas cap and blow in tank and it will crank back up and run fine. What could this be. I am thinking maybe a bad fuel pump or sreen in fuel tank. Just have not had time to check it out yet
 

·
Super Moderator
Joined
·
6,896 Posts
I just got a 2010 ranger crew 800 handle weeks ago and have been having an issue with it shutting down while going on 5 to 10 minute ride at close to full throttle. when it shuts down it will act like it is not getting any fuel and sputter and backfire and then come to a stop. Kind of like a fule filter stopped up. I will get off and open up the gas cap and blow in tank and it will crank back up and run fine. What could this be. I am thinking maybe a bad fuel pump or sreen in fuel tank. Just have not had time to check it out yet
I would check and make sure the tank vent line ( located under driver seat in the seat frame rail) is not kinked/clogged and the vent valve is working properly. You should be able to blow air into it, but non should come out.Another thing to check is the fuel pressure, if the previous owner sprayed water in the seat base frame (and did not extend the vent lines) the water and dirt has entered the fuel tank and clogged the vent and will destroy the pump, If this is the case I would remove the fuel pump and tank and clean them.
 
1 - 3 of 3 Posts
Top