PRC Polaris Ranger Club banner

2011 Ranger 800XP Won't Start

14706 Views 23 Replies 6 Participants Last post by  RangerXpDriver
Went to use my Ranger today only to discover it will not start. The engine cranks over normal but there is no attempt at starting. It was running normal when I parked it a couple of days back.

I am sure that it could be many things but would like to ask you guys for a few more common failure points to start checking.


Sent from my iPhone using Tapatalk
1 - 13 of 24 Posts
I guess I posted too quick. Found mud clogged in the end of the clear vent tube. Cleared the mud and it started right up!

Sent from my iPhone using Tapatalk
Well,apparently its not over yet. I tried starting it this afternoon and it will not. Same as yesterday, it will crank over but no start. After it started yesterday, I drove it for a few minutes. It never skipped a beat. Any suggestions on where to begin?
Thanks for your reply jungleman. I found no codes. I inspected the CPS sensor and harness. Everything looked good. I was about to unplug the sensor and inspect closer when I decided to see if it would start first. It started up and idled a little rough at first then smoothed out.

At that point I decided to give it a good healthy dose of sea foam and take for a half hour ride on the farm. It never skipped a beat. I guess I will try it again tomorrow evening.

Sent from my iPhone using Tapatalk
I decided to check the machine this morning before leaving for work and once again it would crank over but not start. I will disconnect the CPS this evening and measure resistance. Service manual says it should have 560Ώ between yellow to white and .5Ώ between black to ground. Any other thoughts on the next step?
I removed the CPS and cleaned. No sign of any filings or major gunk. Actually was able to clean with a shop rag. Checked resistance, 532 ohm between yellow and white wires and open between black to ground.

Cranked for several seconds then pulled a plug. It was dry. The fuel pump is coming on each time the ignition switch is turned on. I cycled it several times without trying to start and then made an attempt. It seemed to make a brief attempt.

I will have to come up with a some way to check fuel pressure as I don't have anything readily available.

As for the mud in the vent tube, I would like to claim stupid. I read on here to check the clear tube an did. It just wasn't the fuel tank vent :) I guess it needed unblocked as well. The real fuel tank looked clean,

Thanks for your replies and suggestions.

Sent from my iPhone using Tapatalk
See less See more
Slingblade fan here too! I wish it didn't have gas in it. Sure would be cheaper to fix!

"What are you doing with that lawnmower blade"
Ok guys I am back. I ordered the Actron CP7838 fuel pressure tester that jungleman recommended in another thread. Nice tester thanks for the recommendation jungleman. I connected it up to the ranger and bled the air out and then tested. I have 44psi when just turning on the switch or during cranking. The spec is 45psi +-2 so I am good. Good news is no $300 fuel pump. Bad news is still got a problem.

Since fuel is good I guess its time to focus on spark. I am going to look at the ignition coil next. Anybody got any other suggestions?

"I like them French fried potaters."
  • Like
Reactions: 1
I used and inline spark plug tester to determine that spark was good, so back to fuel delivery. I decided to pull the air filter and give it a shot of starting fluid to see if it would hit on it (don't particularly like doing this). It did so I gave it another shot and this time it continued to run :confused:. I let it idle for a while then shut if off. It restarted as normal. Since I had the air filter out, I blew it out. It wasn't very dirty.

Took it out for a ride on the farm without any problems. Will see what it does tomorrow.
No offense taken here Larry. Actually thought it was funny and a good reminder to take a step back and check the basics. Anyway back to the Ranger, I tried again to start Monday without success until I pulled the air filter. It then stumbled a little but started. This evening it would not start so I inspected the whole air intake system. I pulled the prefilter element from under the hood. It was good. I had also picked a new primary filter. None of this made any difference.

I removed to the IAC valve, inspected it and its wiring harness and did not see any problem. I removed it and did a resistance test per the service manual. All readings were within spec. I connected the harness to the valve and turned on the ignition switch. The valve opened slightly. A few seconds after turning off the switch the valve opened more (maybe to full) and then closed. I believe it to be working properly.

After putting everything back together, it still would not start so I gave it a shot of starting fluid with with which it started. I let it warm to 150 or so then cut it off for a few minutes. It started and ran normally. I am not sure what is next. I have been looking at the T-MAP sensor but the manual says it has to be checked with software. That means that I either take it to the shop or just buy another sensor. I am not really interested in throwing parts at this.

I am starting to wonder if I just have bad fuel. Not sure where to go next.....any thoughts?
See less See more
Siphoned the gas out of the ranger yesterday and poured in 5 gallons of 93 no ethanol fresh out of the pump. Had to give it a shot of starting fluid to start. Used the ranger several times with no problem starting. Ranger started normal today after sitting for over 24 hours. I guess I should of started with replacing the gas first but then I wouldn't have gotten this degree in Polaris :)
  • Like
Reactions: 1
I had put fuel in it about 2-3 weeks before all of this started and just used it on short trips deer hunting on the farm. The ranger sat for about a week when the no start showed up. Anyway, I checked again this evening and it started normal for the second day in a row. I believe this problem is resolved. Thanks to all that replied.
I have been having similar issues with my 570. It has been fouling plugs every 2-3 times I drive it. It only has 77 hours on it. The have changed the map sensor it helped get cranked but won't run right. Just wondering if you ever found the exact problem.
I am now certain that my problem was bad fuel. Since draining and replacing the fuel, I have had no more problems.
  • Like
Reactions: 1
1 - 13 of 24 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.