PRC Polaris Ranger Club banner
1 - 4 of 4 Posts

·
Registered
Joined
·
3 Posts
Discussion Starter · #1 ·
So I am getting 520270 sub 5 and 520269 sub 5 error codes and the machine will not start without throttle and will not idle on its own. Starts and runs fine with a little throttle but dies as soon as you let off the pedal.

I have replace IAC valve and wire harness as well as MAP sensor and harness. The only thing left is the TPS and harness. Could that be my problem? The codes don't relate to the TPS?
 

·
Administrator
Joined
·
7,841 Posts
Clint, you still have a problem with that IAC harness you installed .



This high quality repair harness typically fixes Polaris engine codes:


  • SPN 634 FMI 7,4,3,5
  • SPN 520270 FMI 4,3,5
  • SPN 520269, FMI 4,3,5
  • SPN 520268 FMI 4,3,5

Some symptoms of a bad Idle air control motor wiring harness are engine will not stay idling, idle will be too high or to low. Engine will die when letting off the gas.
 

·
Registered
Joined
·
3 Posts
Discussion Starter · #3 · (Edited)
That was kind of my suspicion so I took the harness off and reinstalled it, and it is still doing the same thing. The check engine light will intermittently go off for a few seconds but will then come back on. I am afraid that the issue is in a wire somewhere between the harness connection and the ecu. I am at a loss.

I just checked the old harness and I don't believe there was anything ever wrong with it. I have continuity on all 4 pins. So new harness and new motor and same problem.
 
1 - 4 of 4 Posts
Top