PRC Polaris Ranger Club banner
1 - 3 of 3 Posts

· Registered
Joined
·
1 Posts
Discussion Starter · #1 ·
I purchased a 2014 Polaris ranger 800xp recently motor was blown up. I rebuilt the the motor with a kalama big bore kit . It ran well for roughly a day would not rev up I noticed was having charging issues replaced the stator. It was fried had picked up a piece of metal but when I replaced everything it all looked normal nothing broken. I also replaced the oil detent spring and dowel that was stuck . I have swapped fuel pumps from my dads 2012 800xp still same thing also replaced injectors and wires. Put new belt and clutch kit on it and put old clutch back on did not change the rpm’s problem. We compression tested it 110lbs on both cylinders and they did not leak off I am at loss does anyone have any ideas I also tried his plug wires and Cdi box.
 

· Registered
Joined
·
15 Posts
I purchased a 2014 Polaris ranger 800xp recently motor was blown up. I rebuilt the the motor with a kalama big bore kit . It ran well for roughly a day would not rev up I noticed was having charging issues replaced the stator. It was fried had picked up a piece of metal but when I replaced everything it all looked normal nothing broken. I also replaced the oil detent spring and dowel that was stuck . I have swapped fuel pumps from my dads 2012 800xp still same thing also replaced injectors and wires. Put new belt and clutch kit on it and put old clutch back on did not change the rpm’s problem. We compression tested it 110lbs on both cylinders and they did not leak off I am at loss does anyone have any ideas I also tried his plug wires and Cdi box.
Did you ever determine what was going on with your unit? it seems VERY similar to my issue, except now i have a crank/ no start...
 
1 - 3 of 3 Posts
Top