PRC Polaris Ranger Club banner

21 - 32 of 32 Posts

·
Registered
Joined
·
18 Posts
Discussion Starter #22
Back on the road this morning.
I have never had to check one before but I will dig into it and let y’all know.
 

·
Registered
Joined
·
18 Posts
Discussion Starter #23
It seems wierd to me that it was running fine prior to the rats.
The last time it really ran it was fine.
 

·
Registered
Joined
·
1,002 Posts
It seems wierd to me that it was running fine prior to the rats.
The last time it really ran it was fine.
If it is something to do with your clutch or belt, it's possible that they made it into the clutch housing through intake or exhaust and made a nest / wreaked havoc in there, lol. Hope you find it.

Another member had posted this picture in the past, but it shows that if a squirrel can get down there, a mouse / rat can definitely do the same and probably get a lot further.

squirrel.jpg
 

·
Registered
Joined
·
2,318 Posts

·
Registered
Joined
·
18 Posts
Discussion Starter #26
Took the cover off and all seemed to be in order. No sign of rat damage.
I started it with the cover off and it actually seemed to run normal.
Drive shaft is still making a lot of noise
 

Attachments

·
Registered
Joined
·
18 Posts
Discussion Starter #27
If I put my hand on top of the shaft and hold a little down ward pressure the noises stop.
Going to grease everything and put back together.
 

·
Registered
Joined
·
1,002 Posts
Is it the front prop shaft or one of the CV shafts going to each wheel that you are talking about?
 

·
Registered
Joined
·
1,002 Posts
You have a crew, so check the carrier bearing on the front prop shaft. I've read about many members having problems with this in the past.
 

·
Registered
Joined
·
18 Posts
Discussion Starter #31
That seems to be where the noise is coming from that bearing
I didn’t know the correct name of it.
 

·
Registered
Joined
·
18 Posts
Discussion Starter #32
Y’all gonna get tired of me eventually.

I finally took the ranger off the jack stands.
The gear shift is pretty hard. It was locked up at first felt like I was going to break it.
But when I put it in gear it tried to take off with no gas pushed then Immediately dies.
I raised the back end up and gave it gas and seemed fine.
I’m almost to the end of my mechanical comfort zone
 
21 - 32 of 32 Posts
Top