PRC Polaris Ranger Club banner

1 - 6 of 6 Posts

·
Registered
Joined
·
3 Posts
Discussion Starter #1
Could anyone help out? My XP 1000 is the north star edition and the fault code 0 520625 5 popped up, and the check engine light is on. I can find most codes but this one I have no clue about.
 

·
Registered
Joined
·
260 Posts
Drive it in low at speeds of no less than 20 mph for no less than 3 minutes. Turn it off, then start it up again. The code will be gone. This is one of the mystery codes Polaris throws every now and again.
 

·
Registered
Joined
·
3 Posts
Discussion Starter #3
Thank you....
I’ll give that a try this afternoon... also would that phantom code cause charging issues? That’s the other problem I am having, already replaced the harness and alternator. Still not getting a charge. I was gonna pull all the clips and clean to verify I didn’t partially connect something.
 

·
Registered
Joined
·
942 Posts
How old is the battery? Batteries on the way out can be a source of many headaches. I've got one in a car right now that's giving me issues. 4 years on sport batteries is long. Can indicate proper voltage but have no amps to crank
 

·
Registered
Joined
·
1 Posts
I also replaced the battery.
I have the same issue 520625 code and check engine light. Also have a charging problem I get 14.5 volts at the battery but at the display 13.0 to 13.4. sometimes slow crank. new battery made no differance. have gone though and checked and cleaned grounds and connections. Glad im not the only one anymore been dealing with this for a year.
 
1 - 6 of 6 Posts
Top