PRC Polaris Ranger Club banner

1 - 9 of 9 Posts

·
Registered
Joined
·
30 Posts
Discussion Starter #1
So....I'm riding my 2013 800 this evening and the checkengine light flashed a couple times. By the time I got home...the light was pretty much constantly on and the Ranger seemed to be 'bogged' down and didn't want to run. Had a 'jumpy' feeling a couple times. Got oil & coolant. I sure can't ride it. Wasn't doing good at all. Any advice/ideas?
 

·
Registered
Joined
·
536 Posts
check your electrical connectors for separation.I have the service manual for my bike and maybe can help you diagnose it if you want.
 

·
Registered
Joined
·
151 Posts
:?: I saw that you said that you found oil in the coolant' is this in the radiator or overflow. If the coolant is in the radiator then I would guess maybe the head gasket has failed.
 

·
Registered
Joined
·
1,086 Posts
By his wording Im not sure if he ment that or was saying that it has oil and coolant in it?
 

·
Registered
Joined
·
536 Posts
manual says if the check engine light is on you can enter the service code by pushing the mode button until you see CK ENG the hold the mode button down to enter the diagnostics code menu.Once there you should see some numbers first on the left should be a number 0-9 which indicates how many codes are there,next number is far right and can be 2-6 digits long which indicates suspected area of fault,next number is bottom right and indicates the fault mode.Use the mode button to see if there are more codes,to exit the menu hold mode button or turn off key but record the codes first.Get your numbers and I can look see where the fault is supposed to be.If its still under warranty then take it to the dealer.
 

·
Registered
Joined
·
536 Posts
seems I missed the sticky with the instructions and codes already posted.
 

·
Registered
Joined
·
1 Posts
Hello, I was reading your posts and thought I'd ask a question about the engine warning light. I am new to UTVs, just bought my first a used 2012 Polaris 800 XP. The engine light came on after driving it about 20 min. There doesn't seem to be any performance issues. I followed the advise (above) and my code is 0 51 and the fault code is 3. It's a long haul to get to a dealer so I thought I'd ask if you knew what the issue might be? Thanks
 

·
Registered
Joined
·
1 Posts
Same problem

So....I'm riding my 2013 800 this evening and the checkengine light flashed a couple times. By the time I got home...the light was pretty much constantly on and the Ranger seemed to be 'bogged' down and didn't want to run. Had a 'jumpy' feeling a couple times. Got oil & coolant. I sure can't ride it. Wasn't doing good at all. Any advice/ideas?




I have the exact same problem but also my 2013 800S was bogging out and then quitting completely turning everything off which makes me think it's electrical also I can hear wires grounding out when it is about to die I have had many problems when it comes to the electrical system which furthers my suspicion
 

·
Registered
Joined
·
1 Posts
Same problem


I have error code 0 520270 4. Anyone know what this is?




I have the exact same problem but also my 2013 800S was bogging out and then quitting completely turning everything off which makes me think it's electrical also I can hear wires grounding out when it is about to die I have had many problems when it comes to the electrical system which furthers my suspicion
 
1 - 9 of 9 Posts
Top