PRC Polaris Ranger Club banner

1 - 9 of 9 Posts

·
Registered
Joined
·
5 Posts
Discussion Starter · #1 ·
2006 Ranger 6x6 700 EFI

Symptoms:
1. Won't idle
2. Engine check light constantly on.
3. Returns code 21 "Loss of synchronization"

I found the CPS, noticed that the prior owner or his mechanic had put electrical tape over the wires near the plug into the CPS. There are only TWO wires going into the CPS. Both are chaffed right next to the plug where it goes into the CPS. Likely the wires were making contact either with each other or with the aluminum "foil" affixed to the bottom of the seat and the electrical tape was not sufficient to isolate them.

With the seat off and the wires separated, the vehicle idles. Although probably a little too slowly. And the engine check light is no longer on.

I cannot find a source for a replacement plug.

What should I do now?

Thanks in advance.
 

·
Registered
Joined
·
5 Posts
Discussion Starter · #3 · (Edited)
136244


A photo is worth a 1,000 words, especially when my words are incorrect.

1. There are, in fact, two chafed wires, but they are on the passenger side fuel injector (not on the CPS which I have failed to locate);
2. The check engine light is now off, but Code 21 still presents when I do the key test 1. on-off, 2. on-off, 3. on and leave on and count the flashes.
3. I can't believe it, but for some reason some how and I don't know when, but the passenger side spark plug wire boot was also off the spark plug.

So it idles ok now, too slow I think, but it idles instead of dying.

I will buy the fuel injector harness.

For good measure, I will also buy some new spark plugs (any recommendations?)

BUT does anyone have a photo of where the CPS is on the engine?

ALSO, can someone recommend a good tachometer for these engines?
 

·
Registered
Joined
·
778 Posts
Get yourself a service manual. The CPS is located on the right side, on the back of the stator cover, towards the bottom.
There is a tach feature on your speedometer cluster if you have one.
 

·
Registered
Joined
·
5 Posts
Discussion Starter · #5 · (Edited)
I bought the OEM Polaris 2005-2006 Ranger XP EWFI, 2006 Ranger 6x6 EFI, Service Manual PN 9920224 when I bought the vehicle.

I joined this forum on December 22, 2010.

Reading the manual is how I learn. That is the reason I have only five posts here.
I read the manual before I created this thread.

Now how about you actually be helpful and either post up a photo of the CPS in its native location or post up the page number or a scan of the page in the Service Manual which shows its location. I looked and can't find one.

So, I came here for help.

Should I have come here for help?
 

·
Moderator
Joined
·
6,910 Posts
E, help is here if you have a need.
 
  • Like
Reactions: E350

·
Moderator
Joined
·
6,910 Posts
E, the CPS is located on the right side of the rear of the engine near the stator output. It is the one that DOESN"T have three yellow wires coming out of it.
 
  • Like
Reactions: E350
1 - 9 of 9 Posts
Top