PRC Polaris Ranger Club banner
1 - 2 of 2 Posts

·
Registered
Joined
·
1 Posts
Discussion Starter · #1 ·
2018 Polaris Ranger XP 1000
11,000+ miles
Transmission very recently replaced due to turf mode failure
Replacement trans did not come with new turf mode solenoid or gear position sensor. Both were working on the old trans, so I swapped them to the replacement trans. With turf mode enabled, going up the shift pattern;
Park- positrack indicated on display
Reverse- turf mode indicated on display with audible click coming from solenoid
Neutral- positrack indicated on display with audible click coming from solenoid
Low- turf mode indicated on display with audible click coming from solenoid
High- turf mode indicated on display with audible click coming from solenoid, which makes no sense to me because it doesn’t indicate switching modes, and shouldn’t be switching modes.
Going down the shifter;
High-turf mode indicated
Low-audible click positrack indicated, but low range not indicated
Neutral- no click, positrack indicated, but neutral not indicated
Reverse- no click, positrack indicated, but reverse not indicated
Park- no click, positrack indicated, but park not indicated
 

·
Registered
Joined
·
1,871 Posts
Park- positrack indicated on display
Reverse- turf mode indicated on display with audible click coming from solenoid
Neutral- positrack indicated on display with audible click coming from solenoid
Low- turf mode indicated on display with audible click coming from solenoid
High- turf mode indicated on display with audible click coming from solenoid
This is all normal operation.
Going down the shifter;
High-turf mode indicated
Low-audible click positrack indicated, but low range not indicated
Neutral- no click, positrack indicated, but neutral not indicated
Reverse- no click, positrack indicated, but reverse not indicated
Park- no click, positrack indicated, but park not indicated
This is definitely not.
 
1 - 2 of 2 Posts
Top