PRC Polaris Ranger Club banner

1 - 11 of 11 Posts

·
Registered
Joined
·
507 Posts
Discussion Starter #1
Ok guys, I’m needing some electrical connector (deutsch, weather-pak, metri-pak) information. I have two electrical solenoids that I currently have a cheap amazon two wire connector on, I’m running two of them, one on each two wire set, if that makes sense. What I would like to do is set it up with one four wire connector, and only run one plug. My question is, which type of connector would you electrical guys prefer? It will be exposed to large amounts of dust, debris, and water (not submerged, if so I have way bigger problems, just rain or light pressure washing).
 

·
Registered
Joined
·
375 Posts

·
Registered
Joined
·
92 Posts
Great info Griffon. I may be using these for my light bar project. It would make things a lot easier if/when I need to take the roof off.
 

·
Administrator
Joined
·
6,360 Posts
I concur with Rob! Weather Paks are usually used for connecting two loose wire groups while Metri Packs are usually used for connecting a loose wire into a stationary plug like a sensor. Deutch connectors are also nice but they are usually only rated for 15 amps.
 

·
Registered
Joined
·
375 Posts
just make sure you get the weatherpack with the correct size terminals for the size wire/amperage needed. I linked to a weatherpack with a smaller gauge wire than what would be needed for a light bar. They also make a 12ga-10ga .
 

·
Registered
Joined
·
507 Posts
Discussion Starter #6
Thanks guys, I’m not sure if the amperage that I’m using but I do know the wires are 20 ga. I’ll look into the weather pack connectors, although the metri packs would be pretty sweet just to plug the wires into the receptacle and be done. So many options...
 

·
Administrator
Joined
·
6,360 Posts
Ruger, if it's an option, run larger wires than 20 gauge. 18 ga and smaller have a tendency to sometimes break due to the vibration of the machines. Curious, what options are you installing that require solenoids?
 

·
Registered
Joined
·
507 Posts
Discussion Starter #8
Fswan, I’ll post a picture up as soon as the uploader starts cooperating again, when I click on the image tool I get a lighter screen but no pop up to select my image location
 

·
Registered
Joined
·
507 Posts
Discussion Starter #9
Also for some reason today I noticed when I hit post quick reply to add a reply i get a error saying I must wait 30 seconds in between posting, I only hit “post quick reply” once, and I haven’t posted within 39 seconds. Feel free to delete this reply once it’s fixed.
 

·
Registered
Joined
·
507 Posts
Discussion Starter #10
And the edit post and reply with quote options seem to be broken as well, they just spin, and don’t do anything.
 

·
Administrator
Joined
·
6,360 Posts
Tech Support has been advised!
 
1 - 11 of 11 Posts
Top