PRC Polaris Ranger Club banner
1 - 3 of 3 Posts

·
Registered
Joined
·
2 Posts
Discussion Starter · #1 ·
Ok so this 2011 ranger has had three new batteries before finding the buss breaker was bad. The guy working on it grabs the housing with breaker and pulls it out, pulling wires lose. I have managed to figure out where two of these go, but i still have one red wire and one black one lose. I couldnt find any one of these wires to be a power source for the hot aide of this breaker, had to run a new wire from battery. This all happened while chNging out the solenoid. I need help, because i dont know what was attached to solenoid and what was not other than the two main wires that go to it and starter. After running the battery dead ten times i finally figured out that the red wire that makes the fuel pump come on went to other leg of that breaker(so i hope) atleast with itlike that the battery will hold up longer than 10 minutes. Does all this make any sense?
Obviously something isnt working because of the two lose wires, today i was able to ride it for 20 minutes or so but then the display started reading low 10.8, can anyone help with this? Its a 2011 rzr 800, also the fan will not come on by itself, i replaced the relay as well, still have to work it with a toggle switch.
 

·
Administrator
Joined
·
7,328 Posts
Ok.... "Ok so this 2011 ranger has had three new batteries " &

"Its a 2011 rzr 800 "........ ????

So Stacy....... If it is a Ranger 800,below is a $10.00 downloadable pdf service manual with the wiring schematics in the back of it..


 
1 - 3 of 3 Posts
Top