PRC Polaris Ranger Club banner

1 - 6 of 6 Posts

·
Registered
Joined
·
5 Posts
Discussion Starter #1
I have a 2017 polaris ranger xp1000 eps northstar. I've been battling a front differential noise that I cant seem to pin point. I've replaced all the bearings and seals in the front differential I've changed the fluid with polairs fluid. Ive watched a lot of videos and some differentials have ring gear shims mine does not have one. I have a 1 peice rhino driveshaft, I've been running for 1500ish miles. U joints have a very tiny amount of wiggle in them. I've removed the drive shaft and the noise is no longer there. The driveshaft yoke at the rear end has a small amount of movement on the splines. Does anyone have any thought or possibly a solution? I also have a video of the noise if that helps any?
131868
131869
131870
131871
131872
131873
 

·
Registered
Joined
·
6,054 Posts
HT , can you post the Youtube ?
 

·
Registered
Joined
·
14 Posts
Sound anything like this...brand new 2021 base 1000 (eps)


One item to note, the joints on the prop shaft are out of phase by 30-40 degrees.

The harmonic resonance is awfully similar to what is being shown in this vid




Called the dealer, I have faith he will fix.
 

·
Registered
Joined
·
5 Posts
Discussion Starter #5
Sound anything like this...brand new 2021 base 1000 (eps)


One item to note, the joints on the prop shaft are out of phase by 30-40 degrees.

The harmonic resonance is awfully similar to what is being shown in this vid




Called the dealer, I have faith he will fix.
That would be super frustrating with a brand new machine!
 

·
Registered
Joined
·
14 Posts
Sure but as long as the dealer backs the issue and makes it right I would call that ok.

Apologies, should have made my own thread anyway...just wanted to see if this issue was the same as OP
 
1 - 6 of 6 Posts
Top