PRC Polaris Ranger Club banner

81 - 91 of 91 Posts

·
Registered
Joined
·
47 Posts
Discussion Starter #81
Haha wow. All this time.......

Really the hose on there isn't even long enough to put anything in there. New top caps are freaking expensive. I will put a vacuum cap on it.

Still waiting on the secondary bumpers to get here.

Thanks for all the help guys. Of course it was the simplest fix.
 

·
Registered
Joined
·
305 Posts
Haha wow. All this time.......

Really the hose on there isn't even long enough to put anything in there. New top caps are freaking expensive. I will put a vacuum cap on it.

Still waiting on the secondary bumpers to get here.

Thanks for all the help guys. Of course it was the simplest fix.
What was there before the rebuild? Had to be something or it would of had the same problem.
 

·
Registered
Joined
·
47 Posts
Discussion Starter #83
Beats me. Only thing nearby there when is the vent line that goes from the oil tank to that little deal under the motor mount. It has always been loose there until a couple days ago when I connected it to the air box.
 

·
Registered
Joined
·
305 Posts
Beats me. Only thing nearby there when is the vent line that goes from the oil tank to that little deal under the motor mount. It has always been loose there until a couple days ago when I connected it to the air box.
Something must have stuffed in there and during your disassembly/reassembly it fell out. I hate when stuff like that happens. Let us know how it's running after you get that cap.
 

·
Registered
Joined
·
981 Posts
Holy sheet! Never seen one like that either! No wonder the slide wouldn't open, talk about a huge vacuum leak. Should run like a champ now!
 

·
Registered
Joined
·
305 Posts
Holy sheet! Never seen one like that either! No wonder the slide wouldn't open, talk about a huge vacuum leak. Should run like a champ now!
I see them on some early 2000's and have never understood why they are there. They are always capped off and I've never seen a hose attached that terminates somewhere. Sometimes the underside of the seat will rub on the rubber cap and put a hole in it so check for clearance once it's all back together.
 

·
Registered
Joined
·
47 Posts
Discussion Starter #89
She runs great now. Just trying to get the pilot screw adjusted correctly. I love how the manual says get engine warm (10 minutes of running before tuning) it is almost the only way to adjust the pilot screw is with a flat head bit from a drill because of the distance between the carb and the cylinder. On top of that every thing is freaking hot!

Thanks for all the help and ideas guys.
 

·
Registered
Joined
·
981 Posts

·
Registered
Joined
·
47 Posts
Discussion Starter #91
Good deal Wrench! 2- 2 1/4 turns out should be close. Not easy to get to for sure. one of these work good for those tasks.

https://www.ebay.com/itm/13-IN-1-Extend-Flexible-Screwdriver-Tool-Driver-Socket-Philips-Flat-Star-New-/401027598865?redirect=mobile
Thanks, I have one similar, you still can see in order to know if you are actually turning the screw or not. I started at 2.5 turns out per the manual, it was chugging and smoking (rich) at idle. Turned in to 1 turn out then the idle would hang after revving. I adjusted the throttle needle height from the 3rd notch to the 2nd notch and set the pilot screw at 2 turns out and now it is perfect. Starts right up, idles smooth, revs and comes right back to idle.

Thanks again everybody.
 
81 - 91 of 91 Posts
Top