PRC Polaris Ranger Club banner

1 - 13 of 13 Posts

·
Registered
Joined
·
263 Posts
Discussion Starter #1
Well, I was checking things out on my 500 crew and I noticed that my carrier bearing on my drive shaft is gone... Non-existent... I can grab the drive shaft and pick it up and down... Lol explains all the noises and vibrations... So anyway I bought a new bearing and I'm trying to figure out how to put it on.... What is the easiest way to get the drive shaft off of the ranger? It is a crew so it's a long one. Any body know where I can fine instructions for this?
 

·
Registered
Joined
·
536 Posts
did mine not too long ago,all you need to do is lift the storage area under the front seat and remove the two bolst that hold the bearing down.mark your driveshaft where they seperate to get them back same way(I didn't and had to align it by eye).Once the 2 bolts are out you can move the shaft to one side and seperate it from the front then remove from the back splines,with the shaft out there are 2 allen bolts that hold the bearing to the driveshaft,loosen them and the bearing slides off.
 

·
Registered
Joined
·
263 Posts
Discussion Starter #3
Well the thing with mine is... Nothing is left... I must have been riding with it broke for a long time. It doesn't look like a bearing is anywhere on this thing. It is just flopping around with metal shavings around it. So how would I align it? I didn't even know it had to be aligned I was thinking it just had a place for it.
 

·
Registered
Joined
·
536 Posts
no allignment for the bearing itself it just slides over the shaft 2 set screws holds it on and the bracket clamps it to the chassis to keep the drive shaft from flopping around.The alignment I was talking about is for the front and rear splines that you will be seperating to get the driveshaft out of the bike,just put a mark across the joint and when its time to reinstall it you will know where to line it up.It is an easy job just have to start and you will see,just hope you didn't damaged the driveshaft from the overly worn bearing.Mine actually seized while out on a ride and I thought something had let go in the tranny,started to smell like rubber burning then the whole bike started to vibrate and you could feel it in the rear tire when rocking it back and forth.
 

·
Registered
Joined
·
263 Posts
Discussion Starter #6
Mine locked up but I kept riding it and eventually the noise went away. That was stupid... Lol I took the bolts out but I can not seem to move it over far enough to get the shaft off...
 

·
Registered
Joined
·
536 Posts
thats all I did was move it to the drivers side untill it slipped out the front yoke,did the same to reinstall.Try rotating it some,maybe the u joint is binding.
 

·
Registered
Joined
·
263 Posts
Discussion Starter #9
I got the front part of the shaft lose. But mine isn't as easy as yours. The rear part of the drive shaft will not budge. Can not get the shaft off the bike. So I tried to replace the bearing with the front being lose and the bearing will not move either. Yes I took the screws out. I tried a 3 jaw bearing puller but it will not grab the bearing ( because nothing is left except for the sleev part that is on the shaft) because it is to thin. Any suggestions or tips?
 

·
Registered
Joined
·
536 Posts
sounds like the rear splines are stuck and should be freed up but the bearing is probably seized to the shaft cuase of the heat of running it seized.You could try cutting it with a cutoff tool in the bike but it would be much easier to get the rear apart and take it out.My shaft slid off the splines very easily but I grease mine very often,maybe you could heat it with a torch in the bike also.You don't have alot of options here,it either cut it off,heat it up or get the shaft out and do one of the two.Maybe try a deadblow hammer to tap the rear shaft off the spline?
 

·
Registered
Joined
·
263 Posts
Discussion Starter #11
Ok I got it. Finally got the shaft off the bike.... Couldn't get the bearing off because I didn't realize it had a snap ring on it. I couldn't see it. It's all good and done and fixed now... Thanks!!!!
 

·
Registered
Joined
·
536 Posts
glad you got it fixed,mine didn't have any snap rings on it just the 2 set screws.
 

·
Registered
Joined
·
1 Posts
Hello i have a 2014 Polaris ranger 900 crew and just changed carrier bearing and re installed drive shaft, since the yolks aren't phased is there a certain way to line up shaft to eliminate vibration? thanks.
 
1 - 13 of 13 Posts
Top