PRC Polaris Ranger Club banner

1 - 4 of 4 Posts

·
Registered
Joined
·
15 Posts
Discussion Starter #1
Hey all,
I have seen an issue/concern where running pedal to the metal, my rig will start to click extremely loudly in the drive-train. The sound 'seems to sound like the unit it not fully engaged in gear... No loss of power/speed but it is so loud that it makes me back out of the pedal and it immediately stops the clicking.
It happens on grass, hard pack trail and pavement. (it has only happened 3 times, 1st on hard trail, 2nd on grass and 3rd time on pavement) The 2nd/3rd times were 'testing' that it occurs on different surfaces. My solution is to simply not run that fast, which is a rarity anyway but I would like to know WHAT/WHY.

Anyone have thoughts on this?
I am not even ready for my 1st service yet on a new '17 500 model (stock except for roof and a MMA kit) with 19hrs and 68 miles on it. (no I don't use it much)

I will certainly address with the dealer upon service but I would like to have an idea or a train of thought going in.

THX!
 

·
Registered
Joined
·
15 Posts
Discussion Starter #3
I will check them, thank you.

Now I should have stated that 'I' think the sound is coming from up front in the foot board/dash area. I have checked the shaft and front diff to the best of my ability.
And this is in turf mode. I don't really drive on 'turf' that I care about so should I stop using it? I don't think I have used 4WD but maybe twice and don't believe I even needed it then but I presume I should use it every now and then just to keep things working.

I really believe I have heard this sound (not near as violently) like when going to reverse and it not quite being there it chatters trying to find it...

Off-topic - Oh how I wish it was a 'gated shifter'!
 

·
Registered
Joined
·
15 Posts
Discussion Starter #4
Revisiting this thread with a 'CAUSE' but not a full resolution!
Turns out it was my ROOF, at high speeds wind going around the windshield caused the sides of the roof to flap against the roll cage. Very small gap, I put packing foam in the gap and it solves it until I trailer it and the wind blows it out each trip. I have done double sided tape, silicone on the foam to try and keep it in place but it only lasts a short while.
 
1 - 4 of 4 Posts
Top