PRC Polaris Ranger Club banner
1 - 11 of 11 Posts

·
Registered
Joined
·
20 Posts
Discussion Starter · #1 ·
Can anyone tell me what to do about my Low range indicator showing up in High. I don't have a high indicator showing up anymore. Where my low is supposed to be,its blank. Reverse shows. 4wd drive works in reverse. But not in the orginal Low indicator spot. Thanks.
 

·
Registered
Joined
·
20 Posts
Discussion Starter · #3 ·
Hey thanks for responding. I can still shift into high. 4wd still works in both even though the Low indicator doesn't show. I'll try the shift cable. tomorrow. Thanks again.
 

·
Registered
Joined
·
22,344 Posts
.....Wondering where the sensor is and where to get a new one?
One the older machines, it was located right behind the shift linkage. Not sure about eh newer machines, but I suspect a similar location. Look for a small (maybe 2.5") round thing shaped like a hockey puck. It would be the only thing on the tranny with wires leading to it. Maybe a member with a new machine can be more precise about the location.

You can get one from any Polaris dealer. If you don't have a dealer near you, contact Chris Ball at Ball Equipment / Fix My Toys. His contact info' is in our sponsors section. Their prices are great and service is second to none.
 

·
Registered
Joined
·
2,038 Posts
Yeah its the shift position sensor. Same thing went out in my 500. Quick way to spend $85 lol
 
1 - 11 of 11 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.
Top