PRC Polaris Ranger Club banner

1 - 8 of 8 Posts

·
Registered
Joined
·
287 Posts
Discussion Starter #1
we installed that 2 piece oem polaris black roof, followed and double checked instructions, have that foam seal between 2 pieces, the shorter piece is front, all bolts in right, thise 2 long C shaped metal brackets in, one middle bar and one back bar located, yet shoot some water on the roof and leaks, or should i say pours like niagra falls inside on front seat, i assume this is not normal? but dont know what steps to take since its installed correctly. anyone else do this? thanks
 

·
Registered
Joined
·
22,957 Posts
I'm sure someone can help you out David. I installed a two-piece steel roof and no leaks at all. Might be something hokey about the instructions.
 

·
Registered
Joined
·
287 Posts
Discussion Starter #3
i hope someone can. maybe i should have bought the steel one to, but in nevada desert at 120 degree summers, well i might bake!
 

·
Registered
Joined
·
20 Posts
I have a 2008 crew with the plastic 2-piece top. The foam tape is a joke, it's mostly there to help with vibration. My dealer told me the only way to keep it from leaking is to use silicone. I bought two tubes of black RTV silicone and went over the seam real good. It worked, I an the wife do not get wet.
 

·
Registered
Joined
·
287 Posts
Discussion Starter #5
thanks! kind of what im doing, took it back off, removed that foam stuff, bought a real rubber marine hatch seal, about 1/2 inch wide, 1/4 inch tall and 6 feet long, placed it in between. then i added 12 more bolts across the seam every -4-6 inches. now i will seal it where they meet with a black silicone and go over the top of the bolts as well. it should work. so were on the same exact thoughts. im glad to hear it worked out for you, gives me hope it will for me to.

chalk one up for tossing the instructions...lol.. appreciate it!.
 

·
Registered
Joined
·
1 Posts
thanks! kind of what im doing, took it back off, removed that foam stuff, bought a real rubber marine hatch seal, about 1/2 inch wide, 1/4 inch tall and 6 feet long, placed it in between. then i added 12 more bolts across the seam every -4-6 inches. now i will seal it where they meet with a black silicone and go over the top of the bolts as well. it should work. so were on the same exact thoughts. im glad to hear it worked out for you, gives me hope it will for me to.

chalk one up for tossing the instructions...lol.. appreciate it!.
curious how this worked out. I bought a 2019 and have had it back to Polaris 3 times and roof still leaks....grrr
 

·
Registered
Joined
·
340 Posts
This is a very old thread....

Do yourself a favor and buy a WhoMoto from @Marty. I went through 2 factory for mounts breaking(not leaking) before I said screw and cut my losses.
 

·
Registered
Joined
·
77 Posts
mine did the same, leaked water at the seam. applied a rubberized bead of sealant at the seam and issue resolved
 
1 - 8 of 8 Posts
Top