PRC Polaris Ranger Club banner

1 - 7 of 7 Posts

·
Registered
Joined
·
4 Posts
Discussion Starter #1 (Edited)
Has anyone else had a problem with their front diff working whenever it feels like it? I bought a new 14 ranger 570 mid last Friday. Took it out to the river Saturday and the 4wd was working here and there. I took it back to dealer Mon and of course it worked fine for them but I left it there , so they could mess with it and see if they could find a loose connection or something. Called Thursday and they said check engine light came on finally and it said incomplete circuit. They said that they think it's the coil in the front diff and ordered and new one, so just waiting on part to come in. And by the way, love the little mid size 570. It is my first sxs and surprisingly quick for a smaller engine. Even with the 4wd not working I only had to get pulled out of the sand one time. Only had 3.5 hours on it when it started actually acting up.
 

·
Registered
Joined
·
4 Posts
Discussion Starter #3
So far, the 2 days I got to use it, it exceeded my expectations. Well all except for the whole 4wd issue. I am kind of worried though, after reading so many bad reviews about Polaris and the reliability. Hopefully I won't have any more issues with it after I get it back.
 

·
Registered
Joined
·
221 Posts
I absolutely love mine, have 100 trouble free hours on it so far. Keep in mind, there are thousands of these machines out there and forums like this are meant to help fellow riders with problems they incur. The vast majority of riders never have a problem that wasn't self inflicted and will never be heard from. While your problem is definitely a defective part, the vast majority of failures appear to be directly related to the weight of ones right foot combined with the amount of alcohol in their system. JM2C
 

·
Registered
Joined
·
28,607 Posts
I agree, the problem with these forums is you mostly see the bad. The people with no issues are out riding. It gives it a skewed perspective.
 

·
Registered
Joined
·
4 Posts
Discussion Starter #6
Couldn't agree with you guys more. I'm still a little on the fence about it but am hoping it was just a fluke deal.
 

·
Registered
Joined
·
4 Posts
Discussion Starter #7
Well, just got off the phone with the service dept. He has been back and forth with polaris with them telling him what to check. So far he checked the coil in the front diff, the ecm, and all the wires and new switch. Everything checked good but it still is not working right and he can't get the check engine light to clear. So he is going to call Polaris back and see what they say and is supposed to call me back tonight.
 
1 - 7 of 7 Posts
Top