PRC Polaris Ranger Club banner
21 - 29 of 29 Posts

·
Registered
Joined
·
1 Posts
The engine dies after driving it for about 15 minutes. After it sits for about 5 minutes it will restart and run fine for about another 15 minutes. It's an 04 500 4x4. What could be wrong?
10 years later mine does the same ;
I hope you guys are around still !!
2010 ranger 500 EF I w 90 hours only
Kept in a dry shelter tent garage all year
Starts right up no problem run for 20 minutes no problem through the fields up the trails then out of nowhere it will just die-
Now it cracks but nothing happens BoD I don’t kill the battery
and then if I wait 15-20 minutes it’ll start right back up again.,, and go along for another 10-15,,,
No sputter just die
Wait for either cool down or
I do open gas cap and it won’t start
It always cranks
So I’ll have to check for spark maybe during the dead period
Someone said maybe the coils overheating and then someone else mentioned maybe the stater is short now when it gets hot
I don’t know !
Any help is appreciated
 

·
Registered
Joined
·
1 Posts
I'm curious how this all turned out! I hope you didn't buy the fuel pump as an electric fuel pump only engages while ignition is in the start position, after that it isn't doing anything.
 

·
Administrator
Joined
·
7,761 Posts
Sounds like classic fuel line vapor lock.
 

·
Registered
Joined
·
1 Posts
I have A 2002 Ranger, have the same problem dies and then starts after about 5 minutes, , checked spark, yes spark, put new fuel pump, checked vent in tank, checked screen and line to tank, removed fuel line from pump and pumping, checked most of the connections under seat, I can run around yard all day long, soon as I go for a few miles it acts like its running out of gas and dies, after about 5 minutes it starts and off you go, Im lost as to what to look for next
 

·
Registered
Joined
·
4 Posts
I have A 2002 Ranger, have the same problem dies and then starts after about 5 minutes, , checked spark, yes spark, put new fuel pump, checked vent in tank, checked screen and line to tank, removed fuel line from pump and pumping, checked most of the connections under seat, I can run around yard all day long, soon as I go for a few miles it acts like its running out of gas and dies, after about 5 minutes it starts and off you go, Im lost as to what to look for next
I’d love to know if you figured this out. My 2001 500 ranger 4x4 is doing the exact same thing. It has a new Amazon fuel pump on it but I don’t have a lot of faith in it.
 

·
Registered
Joined
·
4 Posts
Check for a plugged fuel tank vent line and pull the pickup tube out of the tank and inspected it for cracks that would allow it to suck air.
thanks for the response. I’ve replace all the fuel lines including the pick up in the tank. New filter. Vent is clear. Runs great around the yard. Once you open it up for a little while it loses power and will pretty much die. Most of the time it will stay at idle but won’t take off until it idles for a little while. This makes me think the fuel pump doesn’t have enough flow to keep up when at higher rpm’s.
 

·
Registered
1998 Ranger 6x6
Joined
·
2 Posts
Well, what a crazy thread...I have replaced the fuel pump and did not cure the problem. After reading about the pickup tube got to thinking that I the pump is sucking air but don't know why it would start and run again for about 5 min or less. Reading about the stronger pump working fine leads me to believe the factory spec pump just cant over come the air leak. Going to take my old pump, which runs fine on stright 12v and see if I can pump gas out of a gas can and if it can it could be in the reserve - run selector switch. I will solve the problem and post it.
 
21 - 29 of 29 Posts
Top