PRC Polaris Ranger Club banner

1 - 12 of 12 Posts

·
Registered
Joined
·
3 Posts
Discussion Starter #1
Hello all,
I have a 2006 polaris ranger that will not shift into High Range anymore. I removed the the shift linkage pin and the lever would not click in the high postion manually. It will shift into Neutral, Low, and Reverse with no issues.
I was driving it, Shifted to low range for a little crossing and tried to shift it back to high and nothing was there. No gear grinding or anything.
Any suggestions would be greatly appreciated.

rbook
 

·
Registered
Joined
·
1,186 Posts
I would pull the cover off, that houses the shifting mechanism, and make sure there is nothing blocking the movement, or broken, first. Search on this forum for commanmderjjones videos on transmission rebuilding. It will give a lot of information on how it works.

Welcome to the PRC. I think most people find this place while looking for a solution to a problem.
 

·
Rally Committee
Joined
·
3,020 Posts
Welcome to PRC
 

·
Registered
Joined
·
22,346 Posts
Welcome to PRC. :)

Let me ask a couple of questions for clarification of the problem.......when you removed the cable from the lever, would it not shift into high range (still stuck in the low range position), or it would shift into the spot that should be high range but not move forward or do anything?
 

·
Registered
Joined
·
3 Posts
Discussion Starter #7
Commander: When i take the cable off the lever on the transmission the lever will roll back about 1.5 inches, and the bike will not move. When the cable is connected the shift lever on the dash will go to the high range spot, but i am still in low range. I moved the lever on the transmission with the motor running and the bike will shift out of low but have no high gear. Thanks for the help.
 

·
Registered
Joined
·
22,346 Posts
When shifting the lever by hand and without the cable attached, does it feel like it's clicking into the detent for high range? If I'm understanding what you're saying, it sounds like it's traveling far enough past low range that it should be. There should be a distinct "click" when you shift into each gear. Just trying to determine if it's an issue with the detent gears (which would be an EASY fix) or something much more serious.
 

·
Registered
Joined
·
3 Posts
Discussion Starter #9
When moving the lever with my hand into neutral or Low there is a distinct "click" on the lever, no click with High. How could I check the detent gears?

Thanks,

rbook
 

·
Registered
Joined
·
1 Posts
Hello, working to get 03 Ranger 500 up and running... well, it runs, but grinding into high. Cable adjusted, idle very low... dogs are worn obviously... I have found some decent priced sportsman twin transmissions... hoping to just by upper gear set. Can you tell me what is actually compatible with the Ranger series 11?

Thank you!!
 

·
Registered
Joined
·
5,419 Posts
1 - 12 of 12 Posts
Top