PRC Polaris Ranger Club banner

21 - 32 of 32 Posts

·
Registered
Joined
·
153 Posts
Discussion Starter #21
Auto spell is the culprit. SATV adjustable camber A Arms is the subject.


Sent from my iPhone using Tapatalk
 
  • Like
Reactions: Mossy700

·
Registered
Joined
·
153 Posts
Discussion Starter #23
Sometimes I think I should read my posts before I hit reply. Crazy right?


Sent from my iPhone using Tapatalk
 

·
Registered
Joined
·
1,028 Posts
Sometimes I think I should read my posts before I hit reply. Crazy right?


Sent from my iPhone using Tapatalk
I knew it was a spelling correction thing as soon as I read your post. I send crazy stuff all the time because of it.
 

·
Registered
Joined
·
153 Posts
Discussion Starter #26
I knew it was a spelling correction thing as soon as I read your post. I send crazy stuff all the time because of it.
Blessing or curse
 

·
Registered
Joined
·
10 Posts
I just installed SATV a arms and can’t get them to take grease. I have removed the zerk and it will pass grease through it but not when installed.
I have read a thread in the General forum with the same problem and their solution was a longer zerk. I don’t seem to have trouble locking on the zerk but who knows.
anyone have similar issues?
I read all of the suggestions and all are valid, but I didn't see where anyone suggested jacking up the end of the vehicle you are lubricating to take the weight off the bushings to allow some slack. It works more often than not.
 

·
Registered
2020 Ranger Northstar Crew Ultimate
Joined
·
561 Posts
I read all of the suggestions and all are valid, but I didn't see where anyone suggested jacking up the end of the vehicle you are lubricating to take the weight off the bushings to allow some slack. It works more often than not.
Why would it work?
 

·
Registered
Joined
·
153 Posts
Discussion Starter #29
I read all of the suggestions and all are valid, but I didn't see where anyone suggested jacking up the end of the vehicle you are lubricating to take the weight off the bushings to allow some slack. It works more often than not.
I tried many different things and so far nothing has worked. I jacked it up and had someone pump grease while I used another jack and moved the a arm up and down, no joy.
I even loosened all the bolts and tried to force the grease through, again no joy.
im going to take the others advice and run it for a bit and try again.
If that doesn’t work, I’ll pull the whole thing down and saturate and cogitate.
 

·
Registered
Joined
·
153 Posts
Discussion Starter #30
That is...saturate me and cogitate the problem.
 
  • Like
Reactions: RJ

·
Registered
Joined
·
1,028 Posts
Are you absolutely sure the zerk isn't bottoming out on the pivot tube? I feel like I could probably force some grease in those GP bushings, but I didn't want to put that much pressure on the seals.
 

·
Registered
Joined
·
153 Posts
Discussion Starter #32
Are you absolutely sure the zerk isn't bottoming out on the pivot tube? I feel like I could probably force some grease in those GP bushings, but I didn't want to put that much pressure on the seals.
I don’t know what else to think. I’ve backed them off and even “bushed them” with fibre washers. Some took grease others did not. The long uppers are the big problem.
I’ve got a locknlube on the way for my new power greaser. More tools is always the answer.
That’s what my wife says...but she makes a funny face when she says it.


Sent from my iPad using Tapatalk
 
21 - 32 of 32 Posts
Top