PRC Polaris Ranger Club banner
1 - 6 of 6 Posts

·
Registered
Joined
·
41 Posts
Discussion Starter · #1 ·
I sure have been having problems with me 09 Ranger 700 lately. The newest problem I am having is i cannot shift gears while the engine is running. It started making a screeching noise when the problem started. The engine does not seem to be at any higher rpms than normal. It shifts very easily when the engine is not running. Every time I restart it it will screech and not shift. I do not like to keep it running because of the noise it makes. I cannot tell where the noise is coming from. I am hoping with this information some one can point me in the right direction in what to check.
Thanks
Phil
 

·
Registered
Joined
·
7,067 Posts
Sounds like the so called "Non Braking Bearing" in your primary clutch has seized up. Common problem since they went with that bearing in 2008. It can be repaired, but in most cases cheaper to buy a new primary. The bearing is in access of $70 and the primary has to be taken down all the way down to replace it. Labor intensive and special tools required. I made my own set up to change that bearing and it is a 50-50 issue if you can save the clutch. I have replaced my own and several for others, but if that seized bearing wears into the shaft that it rides on then you have no choice but to buy a new primary clutch.
 

·
Registered
Joined
·
618 Posts
People have also experienced this issue when a new belt is installed. Have you replaced the belt recently?
 

·
Registered
Joined
·
22,344 Posts
I'd say that Ken is probably right about the primary bearing. If the idle speed is correct (not too high) and it will only shift with the engine shut off, then it's almost certainly a primary issue and that bearing is the most likely culprit.
 
1 - 6 of 6 Posts
Top