PRC Polaris Ranger Club banner

1 - 8 of 8 Posts

·
Registered
Joined
·
15 Posts
Discussion Starter #1
When I pulled my 2015 FS 570 apart and was cleaning the air intake components up I pulled the BOOT-THROTTLE BODY (item 26) out and where it went into the WELD-INTAKE,PLENUM (item 31) it was coated with a white greasy substance, like lithium grease or something, I assume to help seal that up better for dust intake issues.

I have no idea what is was coated with. Anyone have any clue what that might've been? When I check for "throttle body boot" on the forum, it took me to a thread on this part: ADAPTER-THROTTLE BODY,ETC (item 4) which, according to the OEM nomenclature, is not the throttle body boot but a throttle body adapter.

The thread had good info, and I will follow it for sure (I've already used Permatex on those surfaces), but for now does anyone have an idea on the stuff on the BOOT-THROTTLE BODY (item 26) or should I even worry about it?
 

·
Registered
Joined
·
5,419 Posts
No idea what that was. You don't have to use anything but some hit the perimeter with a narrow coat of high temp sealant just....................to make sure.
 

·
Registered
Joined
·
523 Posts
Do you see the white stuff on the INSIDE of #26/31? I've seen a light coating of it before that was a mixture of oil vapor and moisture.
 

·
Registered
Joined
·
15 Posts
Discussion Starter #5
Do you see the white stuff on the INSIDE of #26/31? I've seen a light coating of it before that was a mixture of oil vapor and moisture.
Only on the throttle body boot where it goes in to the Plenum (item 31). It looked like it was coated with white lithium grease. The boot has a fitting that goes inside the plenum hole, with a lip that fits over the outside and as sealed up with a hose clamp. The fitting that goes inside the plenum hole is what had the white stuff on it.


Screen Shot 2020-02-20 at 11.41.57 AM.png
 

·
Registered
Joined
·
523 Posts
It does sound like it was coated with lithium grease. I don't think they come that way from the factory so if you're not the original owner maybe the previous put it there. It's a really good seal so I'm not sure why it'd be there.

While your working on it have you checked your crankcase vent tube? They get cooked from the exhaust manifold and develop a hole. They've updated the hose and the new one is reddish instead of black.
 

·
Registered
Joined
·
523 Posts
It does sound like it was coated with lithium grease. I don't think they come that way from the factory so if you're not the original owner maybe the previous put it there. It's a really good seal so I'm not sure why it'd be there.

While your working on it have you checked your crankcase vent tube? They get cooked from the exhaust manifold and develop a hole. They've updated the hose and the new one is reddish instead of black.
 

·
Registered
Joined
·
15 Posts
Discussion Starter #8
It does sound like it was coated with lithium grease. I don't think they come that way from the factory so if you're not the original owner maybe the previous put it there. It's a really good seal so I'm not sure why it'd be there.

While your working on it have you checked your crankcase vent tube? They get cooked from the exhaust manifold and develop a hole. They've updated the hose and the new one is reddish instead of black.
Thanks BPS. I'm not gonna worry about the grease.

Yeah, I've got the new crankcase tube. I've also wrapped my exhaust as additional protection.
 
1 - 8 of 8 Posts
Top