PRC Polaris Ranger Club banner

1 - 9 of 9 Posts

·
Registered
Joined
·
309 Posts
Discussion Starter #1
While in 4wd and the front engages, I can only describe it as a vibration. You can hear it as well. It started when I was dragging a Harrow rake up my driveway. I recently changed the front differential fluid and there wasn't any metal shards. Any ideas what my issues is?
 

·
Registered
Joined
·
309 Posts
Discussion Starter #2
No one has any suggestions?
 

·
Registered
Joined
·
28,607 Posts
Its actually a common complaint. The RZRs do it too. Its kind of a buzzing sound while in 4 wheel drive.
 

·
Registered
Joined
·
309 Posts
Discussion Starter #4
Thanks. I hate that these things keep popping up and never had them happen before.
 

·
Registered
Joined
·
22,346 Posts
Yeah, my '12 RZR4XP (900) does the same thing. My old '06 XP never did that.
 

·
Registered
Joined
·
309 Posts
Discussion Starter #6
I appreciate the response. I was worried I had a 4wd issue with snow here and that's my plow for 1500 foot driveway
 

·
Registered
Joined
·
213 Posts
Just caught this sound on my '15 900 crew this weekend. It was a vibration that I thought I could feel through my feet more than I could hear... almost a very low pitched sound. Only does it while running in awd with decent speed through sugar sand. Almost like maybe the drive shaft was a little out of balance
 

·
Registered
Joined
·
309 Posts
Discussion Starter #8
Yup. Same sound
 

·
Registered
Joined
·
635 Posts
mine does the same thing. my older rangers didn't seem to do it, but they also weren't near as quiet as my 900.
 
1 - 9 of 9 Posts
Top