PRC Polaris Ranger Club banner

1 - 7 of 7 Posts

·
Registered
Joined
·
179 Posts
Discussion Starter #1
I pulled the tracks off my '15 900 XP yesterday for the summer and did the usual full service / grease at the same time. Dropped the front diff oil and found a few "flakes" in the oil/ stuck to the drain plug magnet. Sprayed it all clean thru the fill plug until all was coming out clean.
Plan on running it for 25-30kms and dropping the oil again to see if there is any further issue. Have about 1300kms on it. Winter time I run the camso tracks, summer is 26" Bighorns on 14" wheels.

Hoping its not a sign of big trouble brewing......
 

·
Registered
Joined
·
179 Posts
Discussion Starter #3
LOL yeah I thought of that AFTER the fact when it had already been dumped into my waste oil container....
 

·
Registered
Joined
·
171 Posts
Mine looks like crap every time I change it. Ive just started changing it every time I do the engine oil because there is so little oil in there. I always have fine material on the magnet but haven't notice any large flakes.
 

·
Registered
Joined
·
171 Posts
I run tracks all winter also, I suppose they give that front diff a beating.
 

·
Registered
Joined
·
179 Posts
Discussion Starter #7
How big were the flakes? Did you take a picture of them?Sent from my iPhone using Tapatalk

I will have to size up my catch basin: may still be some on there.
 
1 - 7 of 7 Posts
About this Discussion
6 Replies
4 Participants
Boomer686
PRC Polaris Ranger Club
PRCforum is the best Polaris forum community to discuss RZR 1000, Crew 900, PRC Ranger Club, XP 900, RZR XP 4 900, RZR 570, HD, 170, RZR-S, XP 900, RZR XP 4 900, ORV, side by side, SSW and off-road information.
Full Forum Listing
Top