PRC Polaris Ranger Club banner

Winch problem

2767 Views 8 Replies 8 Participants Last post by  bmulcahy
I was hoping that someone could help me out with a problem that I have with my winch.

I installed the standard Warn winch when I bought my Ranger 2 years ago. I've never had to use it. Today I tried to use the winch to pull my riding mower out of a jamb (that's another story).

The winch wouldn't work. I was able to switch the clutch to pull out some cable, but whenever I use the switch to activate the winch, I just get a clicking noise from winch control box that hooks to the battery. I tired both in and out and just the clicking noise. I tried it with the Ranger's engine running and not running. I tried all of the wiring connections, and it seems like everything is connected ok.

I'm sure that the winch worked 2 years ago when I first installed it, but now nothing.

Anyone have any ideas???? Any ideas would be much appreciated.
1 - 9 of 9 Posts
Might sound dumb, and maybe you already checked, but all the wiring connections have to be clean and tight. If it hasn't been used for some time, the connections could be dirty or loose or both. Remember, if you don't use it, you lose it. I start and use things all the time to make sure they work, and sometimes they don't. Good luck.[:)]
Is it the solenoid making the noise or is it coming from the winch?
If it's coming from the solenoid, it's making contact - make sure (with a light tester) that it's sending power to the winch - if it is you have a problem in the winch. You should also be able to put the tester on one of the leads on the winch when you energize it through the the control and get a light if it's sending power - try it
Another idea -- and this make require having a friend to assist -- would be to 'jump' the winch by by-passing the relay. If you try this, I'd use regular jumper cables to be certain that you're using heavy enough gauge wire. A good tester will tell you the same thing, but at least this way if the winch is operable, you can get your cable back in.
Good thinking. I'd try that first.
If it hasn't been used in a while, I would say that it is probably rusted up on the inside of the motor and that is why it is not turning. If you ever had it in any water, it is probably shot.
I hadnt used mine in about a year, and it wouldnt work either. Mine was all full of mud, and the lack of use corroded the armature. I took it apart, and cleaned everything, and relubed it all. It has worked fine ever since.
You can jump it real easy with a battery charger. It's going to work or not.
Thanks for all of the replies. The comment about use it or lose it was accurate. The clicking was coming from the winch relay. Well, I tried it a few more times, and the winch started working.

I guess the relay contacts had gotten corroded, and the more I tried it it must have cleaned itself a bit.

The winch itself would move freely because I could manually pull out the cable. The vehicle itself has never seen mud. I live in California where we don't have any mud[:)]

Thanks again!
1 - 9 of 9 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.