PRC Polaris Ranger Club banner

1 - 8 of 8 Posts

·
Registered
Joined
·
3 Posts
Discussion Starter #1
I have a 2007 700 ranger. one day I was spraying weeds in the hays field and it just died and had no fire. towed it to the house and replaced the main fuse (blown). started right up until I put it in gear, boom fuse blown. I repeated this with the same results. Any Idea's
 

·
Registered
Joined
·
5,989 Posts
Errrrr, you have a short :)..... I would check the battery cables, especially the one to the starter for chafing on the engine.......
 

·
Registered
Joined
·
3 Posts
Discussion Starter #3
Errrrr, you have a short :)..... I would check the battery cables, especially the one to the starter for chafing on the engine.......
thank you I will. but why wouldn't it do it when it starts if there is a short instead of waiting till I put it in gear?
 

·
Registered
Joined
·
5,989 Posts
thank you I will. but why wouldn't it do it when it starts if there is a short instead of waiting till I put it in gear?
Ahhhhhhhhhhh....but the question should be............why does it short when you put it in gear ????? o_Oo_Oo_O
 
  • Like
Reactions: Rooster59

·
Registered
Joined
·
3 Posts
Discussion Starter #5
I'm down with that, any thoughts? some of the terrain is rough underbrush that I went through but there isn't, aren't any wires underneath. is the shifting linkage external and maybe getting pinched while in gear?
 

·
Registered
Joined
·
5,989 Posts
rd, nothing about being in gear would blow the fuse. Vibration or movement may be causing the intermittent short. Make sure the ECU is plugged in properly .
 

·
Registered
Joined
·
942 Posts
Maybe should have went organic instead of using Ranger Pro and killed his ride:)
 
1 - 8 of 8 Posts
Top